Fiddler Ideas

The free web debugging proxy for any browser, system or platform.

FiddlerCore4 does not work with latest Microsoft Message Analyzer

I downloaded FiddlerCore by today because Microsoft Message Analyzer requires it if one wants to inspect HTTPS traffic. It seems that version 4.6.20172.35715 of the FiddlerCore library is no longer compatible with Microsoft Message Analyzer. What I can guess from the error message given by the MMA is, that an overload of a certain method has been removed (or changed); to be specific MMA expects a method named Startup(int, bool, bool) in Fiddler.FiddlerApplication...

  • Matthias Friedrich
  • Dec 8 2017
Bug
  • Attach files
  • Eric Lawrence commented
    December 13, 2017 17:52

    Microsoft Message Analyzer is asking you to pirate FiddlerCore in order to use their product because they do not want to pay to license FiddlerCore. It's beyond comprehension why a billion dollar software company is trying to rip off a much smaller software company, but that's what's happening here.

    Please complain to Microsoft.